<
 
 
 
 
×
>
hide You are viewing an archived web page, collected at the request of Simon Fraser University using Archive-It. This page was captured on 03:36:23 May 09, 2018, and is part of the Public Knowledge Project collection. The information on this web page may be out of date. See All versions of this archived page. Loading media information

We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5152 - XML Galleys plugin mixes xml_galley_id and galley_id
XML Galleys plugin mixes xml_galley_id and galley_id
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.2.5
PC Linux
: P5 enhancement
Assigned To: Alec Smecher
: 5135 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-15 10:00 PST by Alec Smecher
Modified: 2010-02-18 12:07 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.2.x (5.90 KB, patch)
2010-02-17 12:49 PST, Alec Smecher
Details | Diff
Patch against OJS 2.3.1 (7.35 KB, patch)
2010-02-17 15:38 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2010-02-15 10:00:34 PST
XML Galleys plugin mixes xml_galley_id and galley_id, potentially corrupting referential integrity.
Comment 1 Alec Smecher 2010-02-17 12:49:10 PST
Created attachment 3022 [details]
Patch against OJS 2.2.x

Also includes patch to bug #5146.
Comment 2 Alec Smecher 2010-02-17 15:38:48 PST
Created attachment 3023 [details]
Patch against OJS 2.3.1
Comment 3 Alec Smecher 2010-02-17 15:39:50 PST
Fixed.
Comment 4 Alec Smecher 2010-02-18 12:07:54 PST
*** Bug 5135 has been marked as a duplicate of this bug. ***