<
 
 
 
 
×
>
hide You are viewing an archived web page, collected at the request of Road Star Clinic using Archive-It. This page was captured on 19:59:21 Feb 25, 2018, and is part of the Road Star Clinic Closure collection. The information on this web page may be out of date. See All versions of this archived page. Loading media information

This is an archived version of the Road Star Clinic. The Road Star Clinic can now be found at www.roadstarclinic.com. Please join us there!

Road Star Forum
Welcome, Guest
Please Login or Register.    Lost Password?
Has anyone else had this problem?
Go to bottom Post Reply Favoured: 0
TOPIC: Has anyone else had this problem?
#558783
signalzero (User)
Gold Boarder
Posts: 915
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Hudson Fl Birthdate: 1970-00-00
Has anyone else had this problem? 5 Years, 3 Months ago  
I have a leather tank bib that has been on the bike for more then 5 years, I removed it the other day to take a look and the entire top of the tank is stained. Have any ideas how to remove the stains?
 
Logged Logged  
  The administrator has disabled public write access.
#558791
SKWEARpeg (User)
Platinum Boarder
Posts: 12885
graphgraph
User Offline Click here to see the profile of this user
Gender: Male Location: Milton, Florida Birthdate: 1958-00-00
Re:Has anyone else had this problem? 5 Years, 3 Months ago  
Is it stained, or has it simply rubbed the shine off the tank?
Try some of the 3M Finesse-itII(a real fine polish), and see if it will perk it back up. I saw some dull spots under mine the last time it was off also. I thought about using a wire brush to rough up the back side of the bib, so it was more like suede, and less smooth and hard, to see if it'd help. I have waxed the tank alot to try and get/keep a good layer of wax down to protect it. Worse case, if you can't get the shine back, but the paint under the clearcoat is still good, you may find a paint shop that will prep and reshoot the clear(this is only something I've wondered about, not done).
 
Logged Logged  
 
  The administrator has disabled public write access.
#558820
Erbman02 (User)
Platinum Boarder
Posts: 7000
graphgraph
User Offline Click here to see the profile of this user
Re:Has anyone else had this problem? 5 Years, 3 Months ago  
or, has the paint oxidized where it has been exposed to sun and the other elements? 5yrs is a lot of time.
 
Logged Logged  
 
  The administrator has disabled public write access.
Go to top Post Reply
Powered by FireBoardget the latest posts directly to your desktop
...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... ...................................................................... -->
New Forum Posts


The Road Star Clinic is a collaborative community of riders who archive and publish user contributed technical data about Yamaha Road Star motorcycles.

Copyright 2003-2007 Road Star Clinic and its respective authors.
<-- -->